Last Updated:
ubuntu

Masih Setia Dengan Ubuntu 16.04 LTS

root
root GNU/Linux

Meskipun sudah 5 tahun sejak rilisnya, namun Ubuntu Xenial Xerus yang saya gunakan masih bertahan sebagai Sistem Operasi sehari-hari.

Update Ubuntu Xenial erus 16.04 LTS

Ada yang menarik saat saya ingin mengupgrade aplikasi pihak ketiga (tidak berada direpository) malah muncul notifikasi seperti berikut;

ludy@gnulinux:~$ sudo apt dist-upgrade 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done

*The following packages could receive security updates with UA Infra: ESM service enabled:
  libpam0g libc-ares2 libdjvulibre-text bluez libwebp5 libdns-export162 libqpdf21 gstreamer1.0-alsa libimage-magick-perl libisccfg140 intel-microcode linux-headers-generic libsndfile1-dev linux-libc-dev vim-common libx11-xcb-dev libnss3-nssdb libcurl3 libxml2-utils libgrilo-0.2-1 gstreamer1.0-plugins-base-apps libpam-modules openssl ruby2.3 bluez-cups libimage-magick-q16-perl imagemagick ntfs-3g git-man libsystemd0 linux-image-generic libgd3 libavahi-glib1 libicu55 binutils libmagickwand-6.q16-2 squashfs-tools bind9-host libavahi-common-data dnsutils libavahi-common3 libpython3.5 python3.5 git python3.5-minimal libisc160 udev gstreamer1.0-plugins-base libpam-runtime isc-dhcp-common libcurl4-gnutls-dev libnss3-1d libx11-6 libudev1 libwebpdemux1 libavahi-ui-gtk3-0 libaspell15 libapr1 apport mysql-client-core-5.7 imagemagick-6.q16 libmagickcore-6.q16-2-extra libisc-export160 libruby2.3 libcaca0 python3-apport avahi-daemon systemd-sysv libavahi-core7 libgcrypt20 libxml2-dev liblwres141 vim-runtime liblz4-1 vim libpam-systemd libgstreamer-plugins-base1.0-0 distro-info-data libsndfile1 gstreamer1.0-x systemd gir1.2-gst-plugins-base-1.0 libssl-dev libssl-doc libwebpmux1 libavahi-gobject0 mysql-common libpam-modules-bin libx11-data aspell libopenexr22 openssh-client libmagickcore-6.q16-2 python-libxml2 libmysqlclient20 avahi-autoipd libdns162 libx11-dev qpdf libx11-doc bluez-obexd libdjvulibre21 apport-gtk libxml2 libnss3 apache2-bin ca-certificates libicu-dev vim-tiny imagemagick-common libmagick++-6.q16-5v5 libisccc140 avahi-utils openexr libpython3.5-stdlib apport-kde libbind9-140 icu-devtools libbluetooth3 sndfile-programs libexiv2-14 libpython3.5-minimal libavahi-client3 curl isc-dhcp-client linux-generic python3-problem-report mysql-server-core-5.7 libcurl3-gnutls libx11-xcb1 libssl1.0.0 tzdata
Learn more about UA Infra: ESM service for Ubuntu 16.04 at https://ubuntu.com/16-04

Ubuntu comes with ABSOLUTELY NO WARRANTY, to the extent permitted by
applicable law.

Karena penasaran, akhirnya saya browsing ke alamat yang tertera diatas.

rilis ubuntu
support ubuntu

Menurut tabel diatas, ternyata saya masih bisa menggunakan sampai tahun 2026 atau 10 tahun dari rilis pertamanya.

informasi ubuntu
ubuntu

Karena saya menggunakan versi Desktop, jadi saya langsung saja eksekusi perintah diatas. 

ludy@gnulinux:~$ sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  libxfont2 linux-headers-4.15.0-142 linux-headers-4.15.0-142-generic linux-headers-generic-hwe-16.04 linux-image-4.15.0-142-generic
  linux-image-generic-hwe-16.04 linux-modules-4.15.0-142-generic linux-modules-extra-4.15.0-142-generic xserver-xorg-core-hwe-16.04
  xserver-xorg-input-all-hwe-16.04 xserver-xorg-input-evdev-hwe-16.04 xserver-xorg-input-synaptics-hwe-16.04 xserver-xorg-input-wacom-hwe-16.04
  xserver-xorg-legacy-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-video-amdgpu-hwe-16.04 xserver-xorg-video-ati-hwe-16.04
  xserver-xorg-video-fbdev-hwe-16.04 xserver-xorg-video-intel-hwe-16.04 xserver-xorg-video-nouveau-hwe-16.04 xserver-xorg-video-qxl-hwe-16.04
  xserver-xorg-video-radeon-hwe-16.04 xserver-xorg-video-vesa-hwe-16.04 xserver-xorg-video-vmware-hwe-16.04
Suggested packages:
  fdutils linux-hwe-tools gpointing-device-settings touchfreeze firmware-amd-graphics xserver-xorg-video-r128-hwe-16.04 xserver-xorg-video-mach64-hwe-16.04
  firmware-misc-nonfree
The following packages will be REMOVED:
  xserver-xorg xserver-xorg-core xserver-xorg-input-all xserver-xorg-input-evdev xserver-xorg-input-synaptics xserver-xorg-input-vmmouse
  xserver-xorg-input-wacom xserver-xorg-video-all xserver-xorg-video-amdgpu xserver-xorg-video-ati xserver-xorg-video-fbdev xserver-xorg-video-intel
  xserver-xorg-video-nouveau xserver-xorg-video-qxl xserver-xorg-video-radeon xserver-xorg-video-vesa xserver-xorg-video-vmware
The following NEW packages will be installed:
  libxfont2 linux-generic-hwe-16.04 linux-headers-4.15.0-142 linux-headers-4.15.0-142-generic linux-headers-generic-hwe-16.04 linux-image-4.15.0-142-generic
  linux-image-generic-hwe-16.04 linux-modules-4.15.0-142-generic linux-modules-extra-4.15.0-142-generic xserver-xorg-core-hwe-16.04 xserver-xorg-hwe-16.04
  xserver-xorg-input-all-hwe-16.04 xserver-xorg-input-evdev-hwe-16.04 xserver-xorg-input-synaptics-hwe-16.04 xserver-xorg-input-wacom-hwe-16.04
  xserver-xorg-legacy-hwe-16.04 xserver-xorg-video-all-hwe-16.04 xserver-xorg-video-amdgpu-hwe-16.04 xserver-xorg-video-ati-hwe-16.04
  xserver-xorg-video-fbdev-hwe-16.04 xserver-xorg-video-intel-hwe-16.04 xserver-xorg-video-nouveau-hwe-16.04 xserver-xorg-video-qxl-hwe-16.04
  xserver-xorg-video-radeon-hwe-16.04 xserver-xorg-video-vesa-hwe-16.04 xserver-xorg-video-vmware-hwe-16.04
0 upgraded, 26 newly installed, 17 to remove and 3 not upgraded.
Need to get 68,9 MB of archives.
After this operation, 335 MB of additional disk space will be used.
Do you want to continue? [Y/n] 

Semoga saja proses ini berjalan lancar sehingga saya masih bisa bersama Xenial Xerus dalam jangka waktu yang lama.

Comments