Last Updated:
bitnami

Mengatasi Error Installasi Bitnami Di GNU/Linux

root
root Software

Saat ingin menginstall Bitnami LAMPP Stack di OS GNU/Linux, ada notifikasi error yang cukup mengganggu.

bitnami error
error bitnami

Namun ternyata hal itu bukan sesuatu yang fatal dan cukup mudah sekali diselesaikan.

Kita tinggal memasang sebut saja library yang dibutuhkan melalui Terminal.

Berikut cuplikan lengkapnya;

ludy@gnulinux:~$ sudo apt install libtinfo
libtinfo5 libtinfo6 libtinfo-dev
ludy@gnulinux:~$ sudo apt install libtinfo5
[sudo] password for ludy:   
Reading package lists... Done
Building dependency tree   
Reading state information... Done
The following NEW packages will be installed:
 libtinfo5
0 upgraded, 1 newly installed, 0 to remove and 24 not upgraded.
Need to get 83,0 kB of archives.
After this operation, 535 kB of additional disk space will be used.
Get:1 http://buaya.klas.or.id/ubuntu focal/universe amd64 libtinfo5 amd64 6.2-0ubuntu2 [83,0 kB]
Fetched 83,0 kB in 0s (339 kB/s)
Selecting previously unselected package libtinfo5:amd64.
(Reading database ... 407399 files and directories currently installed.)
Preparing to unpack .../libtinfo5_6.2-0ubuntu2_amd64.deb ...
Unpacking libtinfo5:amd64 (6.2-0ubuntu2) ...
Setting up libtinfo5:amd64 (6.2-0ubuntu2) ...
Processing triggers for libc-bin (2.31-0ubuntu9.2) ...
ludy@gnulinux:~$

Untuk Distro versi lainnya mungkin akan ada perbedaan, seperti yang saya praktikkan pada Linux Mint Ulyana

ludy@gnulinux:~$ sudo apt install libtin
libtinfo5              libtins4.0             libtinyxml2-6a
libtinfo6              libtins-dev            libtinyxml2-dev
libtinfo-dev           libtinyxml2.6.2v5      libtinyxml-dev
libtins                libtinyxml2.6.2v5-dbg  libtinyxml-doc
ludy@gnulinux:~$ sudo apt install libtinfo5
[sudo] password for ludy:      
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  libtinfo5
0 upgraded, 1 newly installed, 0 to remove and 552 not upgraded.
Need to get 83,0 kB of archives.
After this operation, 535 kB of additional disk space will be used.
Get:1 http://kartolo.sby.datautama.net.id/ubuntu focal/universe amd64 libtinfo5 amd64 6.2-0ubuntu2 [83,0 kB]
Fetched 83,0 kB in 0s (197 kB/s)   
Selecting previously unselected package libtinfo5:amd64.
(Reading database ... 287386 files and directories currently installed.)
Preparing to unpack .../libtinfo5_6.2-0ubuntu2_amd64.deb ...
Unpacking libtinfo5:amd64 (6.2-0ubuntu2) ...
Setting up libtinfo5:amd64 (6.2-0ubuntu2) ...
Processing triggers for libc-bin (2.31-0ubuntu9) ...
ludy@gnulinux:~$ 

Setelah dependensi tersebut terselesaikan, aplikasi Bitnami pun sudah bisa dijalankan.

Comments